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Getting started guide for programming Move-X Cicerone board

Introduction

The purpose of this document is to guide user through the programming steps of the Move-X
Cicerone board.
Several examples for each type of workspace and Operating System will be illustrated.

For more resources, news, and links to official distributors for Move-X products, please visit Move-

X website: https://www.move-x.it/.
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Integrated Development Environment
(IDE)

The Cicerone is a Move-X MAMWLE based board, which contains a powerful STM32WLEx
microcontroller from STMicroelectronics.
ST provides a complete set of STM32 tools for firmware development and debugging/uploading.
Based on STM32duino project, Move-X also provides an Arduino IDE support package that
includes compiler and uploader as well.

Arduino IDE

Arduino Software (IDE) is an open-source cross-platform software for fast and easy code
development which run on microcontrollers; starting from v1.6.4+ it officially supports third party
boards (e.g., Move-X Cicerone board).

After you have downloaded and installed a version 1.8 or higher of Arduino IDE you can add the
Move-Xduino support (https://www.github.com/Move-X/Move-Xduino) from preferences:

. =P Proferences X
& Blink | Arduine IDE 2.0.0
. — Settings Network
File Edit Sketch Tools Help
Sketchbook location
- c\Users\lgor\Documents\Arduine BROWSE
Cirl + O [ Show files inside Sketches
Editor font size: 14
Open Recent =
Interface scale: 4 Automatic 100
Sketchbook Theme: Light (Arduino) v
Examples Language: English v (Reload required)
Close Show verbose output during ] compile (] upload
Compiler warnings MNone v

Save [ Verify code after upload

Save As... Ctrl + Maiusc + S i B Auto save

[ Editor Quick Suggestions

Additional boards manager URLs: https://github.com/Move-X/MAMWLE_ArduinoSupport/raw/main/package_move- o

Preferences...

Advanced

Quit Cirl + Q CANCEL n

File -> Preferences -> Additional Boards Manager URLs: https://github.com/Move-X/Move-

Xduino/raw/main/package _move-x_indexjson

Now from Tools -> Board -> Boards Manager... type in search bar “Move-X" and you will quickly
find the “"MAMWLE based boards” package as following image. Install the latest available version.
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BOARDS MAMAGER

Move-X

Type: Al w

MAMWLE based boards by Move-X

Version 1.0.0
Boards included in this package:

Cicerone, Generic MAMWLE
Mare info

You can select Cicerone board from Tools and specify serial port, as well as your preferred
upload method (Serial or SWD). See programming chapter for further details.

(&l Blink | Arduino IDE 2.0.0
File Edit Sketch Toolk Help

Auto Format
Archive Sketch
Manage Libranies...
Senal Monitor

Serial Plotter

Board: "Cicerone” Boards Manager...

Version

| Get Board Info
Boards i Arduino AVR Boards

WiFi101 / WiFiNINA Firmware Updater MAMWILE based boards v Cicerone
Upload 551 Root Certificates Generic MAMWLE

Debug symbols and core logs

Optimize

C Runtime Library

Upload method
U(S)ART support

Burn Bootloader
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STM32CubelDE

STM32CubelDE is an all-in-one multi-OS development tool, which is part of the STM32Cube
software ecosystem. STM32CubelDE is an advanced C/C++ development platform with
peripheral configuration, code generation, code compilation, and debug features for STM32
microcontrollers and microprocessors.

ws_temp - 5STM32CubelDE — [m] X
File Edit Source Refactor Mavigate Search Project Run Window Help
g v ving Erav i@y BrOrQGr ™4~ - - = - 0 Q ®\| Bt
{5 Project Explorer x . i =0 = 0 EQu.x ®Bu. - O

There are no projects in your workspace.
To add a project: There is no active editor
that provides an outline.

[ Problems & Tasks & Console % [CProperties = B i Build Ana.. > &= StaticSta.. + Search = B
* ™ - =t

No consoles to display at this time.

Memory Regions Memory Details
Region Start address End address  Size

Typically, every project starts with auto-generated code from STM32CubeMX.
Target microcontroller, of Cicerone board, is the STM32WLESJx.

There are some ready-to-use examples in Move-X GitHub repository written for STM32Cube
environment:

e https://github.com/Move-X/end node mamwle

o https://github.com/Move-X/end_node_freertos_mamwle
o https://github.com/Move-X/LoRAWAN_AT_Slave
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USB Drivers for Cicerone board

The Cicerone board comes with an USB-to-Serial adapter mounted onit. It is based on the Silicon
Labs CP2102N module.

Thanks to this, you can communicate with the MAMWLE module as well as program it.

If you don't have the CP210x VCP Drivers installed on system, you can download it from
https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers

For Linux and MacOS users, the CP210x driver should be natively present in kernel. If this is not the
case, follow the previous link.
In Windows, the Cicerone board appears as a “COM*” device (e.g., “COM4"):

= Jungo
3 Monitor

SEE altn dispositivi di puntamento
W Porte (COM e LPT)

iR Silicon Labs CP210x USB to UART Bridge (COM4)

@ Schede di rete
A crhadavidan

In Linux it appears as a “ttyUSB*” device:

~ Ls /dev/tty*

/dev/tty /dev/ttyl9 /dev/tty3 /dev/ttyd0 /dev/tty51 /dev/tty62

/dev/tty0 /dev/tty2 /dev/tty30 /dev/ttyd4l /dev/tty52 /dev/tty63

/dev/ttyl /dev/tty20 /dev/tty31l /dev/ttyd2 /dev/tty53 /dev/tty7
/dev/tty2l /dev/tty32 /dev/tty43 /dev/tty54 /dev/tty8
/dev/tty22 /dev/tty33 /dev/ttyd44 /dev/tty55 /dev/tty9
/dev/tty23 /dev/tty34 /dev/ttyd5 /dev/tty56 /dev/ttySeO
/dev/tty24 /dev/tty35 /dev/ttyd6 /dev/tty57 /dev/ttySl
/dev/tty25 /dev/tty36 /dev/ttyd7 /dev/tty58 /dev/ttyS2
/dev/tty26 /dev/tty37 /dev/tty48 /dev/tty59 /dev/ttyS3
/dev/tty27 /dev/tty38 /dev/tty49 /dev/tty6 |/dev/ttyUSBO
/dev/tty28 /dev/tty39 /dev/tty5 /dev/tty60

/dev/ttyl8 /dev/tty29 /dev/tty4d /dev/tty50 /dev/tty6l

In MacOS it should appears as a “cu.usbserial*” device (please allow system access to the board
after first connection; a popup should be displayed asking that):

@ Arduino File Edit Sketch | Tools| Help

Auto Format

4 4R B 1

O B E Archive Sketch

@3 @ ;,B "{% Fix Encoding & Reload
Serial Monitor
Serial Plotter

WiFi101 Firmware Updater

Board: "Arduino/Genuino Uno"

Port: "/dev/cu.usbserial-00406114" Serial ports

Get Board Info /dev/cu.Bluetooth-Incoming-Port
e e e [devieiripss-aerialy

Programmer: "AVRISP mkil" Jdev/cu.lpss-serial 1

;B Botosder 'V [dev/cu.usbserial-00406114

Www.move-X.it

info@move-x.it



https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers

pag. 6

Demo Code inside Cicerone Board

The Cicerone Board comes with a preloaded Demo Firmware for the GNSS module evaluation.
The GNSS module by U-blox communicates, by default, with a serial UART interface. The
preloaded firmware inside Cicerone Board let you access the GNSS UART interface from the USB
connection.

If you open a serial connection with a terminal (like the Serial Monitor in Arduino IDE), setting
baudrate to 9600, you will get something like in figure.

(56

,99.99,99.99,1#33
99,99.99,99.99,3+31
99,99.99,99.99,4%36

,99.99,99.99,5%37

Those are ascii-formatted message strings of NMEA protocol. It is a standard protocol for GNSS
positioning.

To evaluate better the GNSS module you can use the free “u-center 2” application by U-blox. You
can download it from https://www.u-blox.com/en/product/u-center clicking on “Download u-

center 2 — For M10 products only”.
® [» Playlog () Racordlog () Comvartiog ® & E

0 Devicos =

a | A device : Tichong,

-
2
=

WD PRY

Davice - COMI

1 OEIE R4 EXS E31 E3D B11 DAD B2 B3 BSW DAT M3 R4 WS A1 BT RED R

Qv 1 [ BAEHALB IR
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If you want to re-flash this demo firmware, you can refer to the “SerialPassthrough” example of

Arduino IDE from “File -> Examples -> [Built-in examples] 04.Communication”

Note: To get a position after first power connection, the GNSS module needs up to 30 seconds (in

outdoor conditions)
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Programming Methods

Based on the chosen development environment there is one or more programming methods
you can use.
Currently there are two options for programming/debugging the Cicerone board:
o USB Serial programming: you will use the USB connector only; it is a programming-only
method
e SWD programming: you will need a SWD programmer like the ST-Link v3; you can also
debug code
In both the cases you will need STM32CubeProgrammer utility. Please install it from
https://www.st.com/en/development-tools/stm32cubeprog.html (if you change the default

settings, be sure to include “bin” folder in system path)

USB serial programming

Hardware setup

Simply connect the USB cable between board and PC.

é-ooooaoooooooo ‘

SWD programming

Hardware setup

Connect SWD cable (STDCI4 to STDC14/STDCI10) between the ST-Link programmer and the
Cicerone, supply power to the Cicerone board by using a USB cable or by giving +5V (e.g. from
ST-Link programmer output pins) to header Vi, then connect USB cable to ST-Link programmer.
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micro-USB

micro-USB

Uploader Tool in Arduino IDE

If you are working with the third-party Move-Xduino support package, you can program (only)
your sketch automatically. You have two options:

e STM32CubeProgrammer-based via USB-to-Serial adapter

e STM32CubeProgrammer-based via ST-Link connector
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& Blink | Arduine IDE 2.0.0

File Edit Sketch Tools Help

o e Auto Format
Archive Sketch
Manage Libraries...

Serial Monitor

’ Q vpe: Serial Plotter
Board: "Cicerone”™
Port

Get Board Info

WiFi101 / WiRiNINA Firmware Updater
Upload 551 Root Certificates

Debug symbols and core logs

Optimize

C Runtime Library
Upload method " 5TM32CubeProgrammer (Serial)

)

U(S)ART support STM32CubeProgrammer (SWD)

Burn Bootloader

In first case you need to select serial port of Cicerone board, while in second case (SWD) you
need to select the serial port of the ST-Link programmer.

Uploader/Debugger Tool in STM32CubelDE

When working on STM32CubelDE, typically you will use the ST-Link programmer so you can also
debug your code. Refer to SWD programming method.

Uploader Tool from command line

When you want to upload an existent .bin/.hex compiled firmware you can choose between two
options:

1. Use STM32CubeProgrammer with Serial connection to the Cicerone target

2. Use Move-X internal tool to directly upload the binary from command line
All of them need the Move-Xduino package to be installed from Arduino IDE environment (see
guide inside this document for installation steps)

(1) sTM32CubeProgrammer

You must enable “boot mode” of target before clicking connect button: to do so, there is a simple
command line tool inside Move-Xduino package
For Windows users:
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« GO to "%LOCALAPPDATA%/Arduinol5/packages/Move-X/tools/MAMWLE _Tool/{version}/"
e Open aterminal in this directory
« execute ".\win\busybox.exe sh .\CiceroneBootControl.sh {mode} {com_port}"
o {mode}:
= "boot" -> enter boot mode (code downloading)
» "run”-> enter run mode (code execution)
o {com_port}:
»  Ex."COMI"
For MacOS users:
« Goto"[Users/{username}/Library/Arduinol5/packages/Move-
X [tools/MAMWLE _Tool/{version}/" (Finder -> Menu -> Go -> [hold option key] Library ->
Arduino 15)
e Open aterminal in this directory
« execute "sh.\CiceroneBootControl.sh {mode} {com_port}"
o {mode}:
» "boot" -> enter boot mode (code downloading)
= "run"-> enter run mode (code execution)
o {com_port}:
= Ex."[dev/cu.usbserial-00406114"
For Linux users:
« Goto"[home/{username}/.arduinol5/packages/Move-
X/[tools/MAMWLE _Tool/{version}/" (is hidden by default)
e Open aterminal in this directory
« execute "sh.\CiceroneBootControl.sh {mode} {com_port}"
o {mode}:
»  "boot" -> enter boot mode (code downloading)
= "run" -> enter run mode (code execution)
o {com_port}:
»  Ex."[/dev/ttyUSBO"

As soon as you have completed the procedure to enter “boot mode” you can click on “connect”
button from STM32CubeProgrammer and proceed with the desired operations (e.g. read/write
flash memory)

Once these operations are completed, click on disconnect and bring the MCU back to “run mode”
using the same procedure as before.
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(2) Move-X Uploader Tool

If you just want to upload a compiled firmware (.bin/.hex) you can use another tool that reduce
the number of operations described before.
For Windows users:
« GO to "%LOCALAPPDATA%/Arduinol5/packages/Move-X/tools/MAMWLE _Tool/{version}/"
e Open aterminal in this directory
« execute ".\win\busybox.exe sh .\stm32CubeProg.sh 1 {file_path} {com_port}"
o {file_path}: file path name to be downloaded (bin, hex)
o {com_port}: Ex. "COMT"
For MacOs users:
« Goto"[Users/{username}/Library/Arduinol5/packages/Move-
X [tools/MAMWLE _Tool/{version}/" (Finder -> Menu -> Go -> [hold option key] Library ->
Arduino 15)
e Open aterminal in this directory
« execute "sh.\stm32CubeProg.sh 1 {file_path} {com_port}"
o {file_path}: file path name to be downloaded (bin, hex)
o {com_port}: Ex. "/dev/cu.usbserial-00406114"
For Linux users:
« Goto "[home/{username}/.arduinol5/packages/Move-
X/[tools/MAMWLE _Tool/{version}/" (is hidden by default)
e Open aterminal in this directory
« execute "sh.\stm32CubeProg.sh 1 {file_path} {com_port}"
o {file_path}: file path name to be downloaded (bin, hex)
o {com_port}: Ex."/dev/ttyUSBO"
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